该版本主要是一个bug修复版本

图片 1

Apache Software Foundation 刚刚发布了Apache HTTP Server 2.2.19
。该版本主要是一个bug修复版本,主要修复了
2.2.18包中存在的问题。该版本是当前最完善的Apache版本,建议用户尽快升级。最流行的HTTP服务器软件之一。快速、可靠、可通过简单的API扩展,Perl/Python解释器可被编译到服务器中,完全免费,完全源代码开放。如果你需要创建一个每天有数百万人访问的Web服务器,Apache可能是最佳选择。该版本Bug修复主要包括:安全警告:CVE-2011-1928
(cve.mitre.org) 对捆绑的APR 1.4.4
apr_fnmatch()的一个bug修复(CVE-2011-0419)引入了一个新的问题。在更新到APR
1.4.4后, 工作进程会被挂起(100%cpu占用率)。通过升级到 2.2.19包自带的APR
1.4.5,或者使用APR 1.4.3以及更早版本的,可以通过设置’IndexOptions’为
‘IgnoreClient’直接避免这几个问题。 2.2.18: 对ap_unescape_url_keep2f()
函数签名的更改不是向前兼容的。这会导致部分第三方模块的不兼容。包
恢复了了该函数签名 保持和 2.2.17
以及之前版本的兼容。详细信息可见:下载地址

相关文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注

网站地图xml地图